xfocus logo xfocus title
首页 焦点原创 安全文摘 安全工具 安全漏洞 焦点项目 焦点论坛 关于我们
English Version

Roxen存在远程文件可访问漏洞


发布时间:2001-08-04
更新时间:2001-08-04
严重程度:
威胁程度:普通用户访问权限
错误类型:输入验证错误
利用方式:服务器模式

受影响系统
Roxen Webserver 2.1
Roxen Webserver 2.0
详细描述
Roxen webserver可以运行在UNIX和WINDOW平台的HTTP服务程序,其中部分可选模块在处理URLS解码的时候存在远程漏洞,可以导致攻击者获得系统任意位置的可读文件。而当CGI模块使用时,这个漏洞运行远程命令可执行。

测试代码
尚无

解决方案
Roxen提供补丁:

Roxen Webserver 2.1:

Roxen patch 2.1 roxen-2.1.247.diff.gz
http://download.roxen.com/2.1/patch/roxen-2.1.247.diff.gz

Roxen Webserver 2.0:

Roxen patch 2.0 roxen-2.0.diff.gz
http://download.roxen.com/2.0/patch/roxen-2.0.diff.gz

相关信息